docusaurus-tailwindcss

Docusaurus v2 plugin to provide support for tailwincss.

Stats

StarsIssuesVersionUpdatedCreatedSize
docusaurus-tailwindcss
100.1.02 months ago2 months agoMinified + gzip package size for docusaurus-tailwindcss in KB

Readme

Tailwindcss for Docusaurus v2

Docusaurus v2 plugin to provide support for tailwincss.

Features

  • Configured with autoprefixer as recommanded in tailwindcss configuration.
  • Native tailwindcss configuration with tailwind.config.js.

Installation

Install the plugin with npm :

npm install --save docusaurus-tailwindcss

or yarn :

yarn add docusaurus-tailwindcss

Add the plugin to docusaurus.config.js :

module.exports = {
  // ...
  plugins: [
    // ...
    'docusaurus-tailwindcss',
  ],
};

Include tailwind in custom.css :

@tailwind base;
@tailwind components;
@tailwind utilities;

Configuration

Refer to tailwindcss configuration.

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.