@olo/ember-principled-forms

Integration of @olo/principled forms with Ember components

Stats

StarsIssuesVersionUpdatedCreatedSize
@olo/ember-principled-forms
0.3.02 years ago3 years agoMinified + gzip package size for @olo/ember-principled-forms in KB

Readme

@olo/ember-principled-forms

Ember.js components which integrate the @olo/principled-forms form handling-library.

Installation

ember install ember-principled-forms

Compatibility

This addon has performance issues with TS versions 3.1 and 3.3. Additional info

Version >=0.3.0 requires the native ember decorators available in ember >=3.10.0 or by adding ember-decorators-polyfill. Otherwise, you'll want to lock to version <=0.2.6.

Usage

[Longer description of how to use the addon in apps.]

Contributing

Installation

  • git clone <repository-url>
  • cd ember-principled-forms
  • yarn install

Linting

  • yarn lint:js
  • yarn lint:js --fix

Running tests

  • ember test – Runs the test suite on the current Ember version
  • ember test --server – Runs the test suite in "watch mode"
  • ember try:each – Runs the test suite against multiple Ember versions

Running the dummy application

For more information on using ember-cli, visit https://ember-cli.com/.

License

This project is licensed under the MIT License.

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.