@nimiq/nano-api

Nano Network API

Stats

StarsIssuesVersionUpdatedCreatedSize
@nimiq/nano-api
640.7.47 months ago3 years agoMinified + gzip package size for @nimiq/nano-api in KB

Readme

[To be Deprecated Soon]

While this library is still in use in our applications, we don't recommend to use it, as it is going to be deprecated soon. Instead, please refer to https://nimiq.com/developers/#tutorials.

Nano Api

A high-level API to the Nimiq nano client. This is intended to be the basis for nimiq wallet applications.

Setup

npm install @nimiq/nano-api

or

yarn add @nimiq/nano-api

Create an Instance:

const config = {
    cdn: 'https://cdn.nimiq.com/nimiq.js',
    network: 'test' // or 'main'
}
const nimiq = new NanoApi(config)

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.