@instructure/canvas-supported-browsers

The official list of browsers supported by Canvas LMS & the Canvas product ecosystem

Stats

stars ๐ŸŒŸissues โš ๏ธupdated ๐Ÿ› created ๐Ÿฃsize ๐Ÿ‹๏ธโ€โ™€๏ธ
3,967307Jun 16, 2021Feb 1, 2011Minified + gzip package size for @instructure/canvas-supported-browsers in KB

Readme

supported-browsers

The list of browsers that should be supported by Canvas LMS and all the products that are part of the Canvas Ecosystem

Canvas supports the current and first previous major releases of the following browsers:

  • Chrome
  • Firefox (Extended Releases are not supported)
  • Internet Explorer 11 (_Windows onlyโ€”_functionally supported; may exhibit slight visual differences from other browsers, but these differences do not restrict product functionality or accessibility)
  • Edge (Windows only)
  • Respondus Lockdown Browser (supporting the latest system requirements)
  • Safari (Macintosh only)

Because browsers are constantly releasing new versions, the actual version numbers that "current and first previous major release" translates to will change over time. click here to see what that currently means

If you are using one of the mainstream browsers that updates itself automatically (eg: Chrome, Firefox, Microsoft Edge or Safari), you should not ever have to worry about this.

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.