@influential/elm

The Elm Platform: Binaries for the Elm programming language.

Stats

stars 🌟issues ⚠️updated 🛠created 🐣size 🏋️‍♀️
00Mar 21, 2018Mar 12, 2018Minified + gzip package size for @influential/elm in KB

Readme

npm install elm Travis build Status AppVeyor build status

Install the Elm Platform via npm.

Installing

Run this to get the binaries:

$ npm install -g elm

Installing behind a proxy server

If you are behind a proxy server, set the environment variable "HTTPS_PROXY".

$ export HTTPS_PROXY=$YourProxyServer$
$ npm install -g elm

Or on Windows:

$ set HTTPS_PROXY=$YourProxyServer$
$ npm install -g elm

Troubleshooting

  1. Troubleshooting npm
  2. On Debian/Ubuntu systems, you may have to install the nodejs-legacy package: apt-get install nodejs-legacy.
  3. If the installer says that it cannot find any usable binaries for your operating system and architecture, check the Build from Source documentation.

Getting Started

Once everything has installed successfully, head over to the Get Started page!

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.