@gmo-media/eslint-config

eslint config for gmo-media.

Stats

StarsIssuesVersionUpdatedCreatedSize
@gmo-media/eslint-config
012.0.14 years ago5 years agoMinified + gzip package size for @gmo-media/eslint-config in KB

Readme

eslint-config

eslint config for gmo-media.

Basic Usage

Install

$ npm install --save-dev eslint @gmo-media/eslint-config

.eslintrc

{
  "extends": "@gmo-media/eslint-config",
  "env": {
    "browser": true
  },
  "rules": {
    "indent": ["error", 2]
  }
}

Rule sets

@gmo-media/eslint-config/legacy

  • for legacy JavaScript.

@gmo-media/eslint-config/es5

  • for modern es5 script. (default)

@gmo-media/eslint-config/es6

  • for es6 script.

@gmo-media/eslint-config/react

  • for React.
  • Please install the eslint-plugin-react.

Development

  1. Edit the rules.
  2. npm test
  3. npm version XXX -m 'message'
  4. git push origin master
  5. git push origin v1.x.x
  6. npm publish --access=public

License

MIT

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.