@gapi/gapi-voyager

##### Original Voyager module you can find here [VoyagerGraphql](https://github.com/APIs-guru/graphql-voyager) ##### For questions/issues you can write ticket [here](http://gitlab.youvolio.com/gapi/gapi-voyager/issues) ##### This module is intended to be

Stats

StarsIssuesVersionUpdatedCreatedSize
@gapi/gapi-voyager
041.2.123 years ago3 years agoMinified + gzip package size for @gapi/gapi-voyager in KB

Readme

@Gapi Voyager Module

Original Voyager module you can find here VoyagerGraphql
For questions/issues you can write ticket here
This module is intended to be used with GAPI

Installation and basic examples:

To install this Gapi module, run:
$ npm install @gapi/voyager --save

Consuming @gapi/voyager

Without configuration

Import inside AppModule or CoreModule

import { Module } from '@rxdi/core';
import { VoyagerModule } from '@gapi/voyager';

@Module({
    imports: [
        VoyagerModule
    ]
})
export class CoreModule { }

With configuration

Import inside AppModule or CoreModule

import { Module } from '@rxdi/core';
import { VoyagerModule } from '@gapi/voyager';

@Module({
    imports: [
        VoyagerModule.forRoot({
            path: '/voyager';
            endpointUrl: '/graphql';
        })
    ]
})
export class CoreModule { }

TODO: Better documentation...

Enjoy ! :)

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.