@finbourne/lusid-sdk-angular6

An angular (6+) SDK for secure access to the LUSID® by FINBOURNE web API

Stats

StarsIssuesVersionUpdatedCreatedSize
@finbourne/lusid-sdk-angular6
0.7.1243 years ago3 years agoMinified + gzip package size for @finbourne/lusid-sdk-angular6 in KB

Readme

LUSID® angular (6+) SDK

This repository enables the generation of an angular (6+) SDK from the FINBOURNE OpenAPI specification using the swagger-codegen tool.

The code required to generate the SDK is in the projects/lusid-sdk-angular6 folder, and the most up to date version of the OpenAPI specification can be downloaded from https://api.finbourne.com/swagger/v0/swagger.json

Generating the SDK

PowerShell

  • auto-generate typescript code from the latest LUSID OpenAPI specification. From the project root folder:

    .\projects\lusid-sdk-angular6\UpdateGeneratedCode.ps1

  • update the version number of the SDK. From the projects\lusid-sdk-angular6 folder:

    update the version in the package.json file (you should not need to do this as the published version should be part of the LUSID CI process)

  • create a new version of the SDK. From the project root folder:

    ng build lusid-sdk-angular6

    This will create the new SDK in dist\lusid-sdk-angular6

  • update the published npm package. From the dist\lusid-sdk-angular6 folder

    cat package.json (to check the version number that will be used)

    npm publish (you should not need to do this as the published version should be part of the LUSID CI process) )

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.