@fastly/prettier-config

Fastly's default eslint configuration

Stats

stars 🌟issues ⚠️updated 🛠created 🐣size 🏋️‍♀️
11Oct 31, 2018Sep 27, 2017Minified + gzip package size for @fastly/prettier-config in KB

Readme

@fastly/prettier-config

Installation

npm install --save-dev @fastly/prettier-config

Configuration

This will give you the recommended ruleset:

// my-app/prettier.config.js
module.exports = require('@fastly/prettier-config')

You can override that as needed:

// my-app/prettier.config.js
module.exports = Object.assign(
  {},
  require('@fastly/prettier-config'),
  {
    lineWidth: 120
  }
)

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.