@debitoor/mocha-strict-dependencies

Mocha test, that checks that you have strict dependencies on your package.json, except of whitelisted

Stats

StarsIssuesVersionUpdatedCreatedSize
@debitoor/mocha-strict-dependencies
311.1.05 years ago5 years agoMinified + gzip package size for @debitoor/mocha-strict-dependencies in KB

Readme

mocha-strict-dependencies Build Status

Mocha test, that checks that you have strict dependencies on your package.json, except of whitelisted

#Usage

npm i -D -E @debitoor/mocha-strict-dependencies
echo "require('@debitoor/mocha-strict-dependencies')([]);" > test/strict-dependencies.spec.js

#Configuration

const listOfPackagesThatShouldHaveUnfixedVersion = [
  'deep-extend',
  'chai'
];
require('@debitoor/mocha-strict-dependencies')(listOfPackagesThatShouldHaveUnfixedVersion)

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.