@colony/eslint-config-colony

eslint configuration for Colony projects

Stats

stars 🌟issues ⚠️updated 🛠created 🐣size 🏋️‍♀️
02Mar 17, 2020Nov 26, 2017Minified + gzip package size for @colony/eslint-config-colony in KB

Readme

eslint-config-colony

The eslint configuration used for Colony OSS projects. Instructions copied from eslint-config-airbnb

Usage

Our default export contains all of our ESLint rules.

Requirements

  • eslint
  • babel-eslint
  • eslint-config-airbnb-base
  • eslint-config-prettier
  • eslint-plugin-flowtype
  • eslint-plugin-import
  • eslint-plugin-prettier
  • prettier

If you use yarn, run npm info "@colony/eslint-config-colony@latest" peerDependencies to list the peer dependencies and versions, then run yarn add --dev <dependency>@<version> for each listed peer dependency. See below for npm instructions.

  1. Install the correct versions of each package, which are listed by the command:
npm info "@colony/eslint-config-colony@latest" peerDependencies

Linux/OSX users can run

(
  export PKG=@colony/eslint-config-colony;
  npm info "$PKG@latest" peerDependencies --json | command sed 's/[\{\},]//g ; s/: /@/g' | xargs yarn add --dev "$PKG@latest"
)
  1. Add "extends": "@colony/eslint-config-colony" to your .eslintrc

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.