@capaj/npm-audit-ci

Commandline utility which exit the process with code 1, for the given criteria of vulnerabilities

Stats

StarsIssuesVersionUpdatedCreatedSize
@capaj/npm-audit-ci
1861.0.53 years ago3 years agoMinified + gzip package size for @capaj/npm-audit-ci in KB

Readme

npm audit ci Build Status

Commandline utility which exit the process with code 1, for the given criteria of vulnerabilities

Useful to make CI build fail when vulnerabilities are found or use to send alert using another tool.

Usage

npm install -g npm-audit-ci
› npm-audit-ci --help                    
Options:
  --version        Show version number                                 [boolean]
  -l, --low        Exit even for low vulnerabilities  [boolean] [default: false]
  -m, --moderate   Exit only when moderate or above vulnerabilities
                                                      [boolean] [default: false]
  -h, --high       Exit only when high or above vulnerabilities
                                                      [boolean] [default: false]
  -c, --critical  Exit only for critical vulnerabilities
                                                       [boolean] [default: true]
  --help           Show help

License

Please see License

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.