@bitcointrade/react-validity

A high-order component made to compose form validations

Stats

stars 🌟issues ⚠️updated 🛠created 🐣size 🏋️‍♀️
01May 31, 2021Jun 7, 2018Minified + gzip package size for @bitcointrade/react-validity in KB

Readme

react-validity

A high-order component made to compose form validations

Getting Started

We use TypeScript in our project, that also means that we bundle the type definitions with the package distribution.

Prerequisites

  • Node.js LTS, although previous versions can still work;
  • We recommend using Yarn as package manager, but you can opt for NPM too.

Installing

Just run the following snippet and you're ready to go:

yarn add @bitcointrade/react-validity

Versioning

We use SemVer for versioning. For the versions available, see the tags on this repository.

License

This project is licensed under the MIT License - see the LICENSE file for details

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.