@59naga/array.from

A ponyfill for the ES 2015 (ES6) `Array.from()`.

Stats

stars 🌟issues ⚠️updated 🛠created 🐣size 🏋️‍♀️
00Apr 27, 2016Apr 5, 2016Minified + gzip package size for @59naga/array.from in KB

Readme

Coveralls – test coverage
Travis – build status
David – status of dependencies
Code style: airbnb

array-from

A ponyfill for the ES 2015 Array.from().

* Ponyfill: A polyfill that doesn't overwrite the native method.
* ES 2015: The new name for ES6 that nobody expected.

Modeled after the final ES 2015 spec. Credits for the implementation go to the amazing folks of the MDN and the amazing guy @barberboy.

 

Installation

$ npm install array-from

Usage

Recommended:

var arrayFrom = require('array-from');
  // You’ll get the native `Array.from` if it’s available.

function () {console.log(
  arrayFrom(arguments).map(require('1-liners/increment'))
);}(1, 2, 3);
//» [2, 3, 4]

You can also use it as a classical polyfill. It’s not recommended, but sometimes practical:

if (!Array.from) Array.from = require('array-from');
  // This will affect all loaded modules.

function () {console.log(
  Array.from(arguments).map(require('1-liners/increment'))
);}(1, 2, 3);
//» [2, 3, 4]

License

MIT © Studio B12 GmbH

If you find any bugs or have a feature request, please open an issue on github!

The npm package download data comes from npm's download counts api and package details come from npms.io.